man.bsd.lv manual page server

Manual Page Search Parameters

VOP_LINK(9) Kernel Developer's Manual VOP_LINK(9)

VOP_LINKcreate a new name for a file

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_LINK(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);

This links a new name in the specified directory to an existing file.

Its arguments are:

dvp
The vnode of the directory.
vp
The vnode of the file to be linked.
cnp
Pathname information about the file.

The pathname info should not be released on exit because it is done by the caller. The directory and file vnodes should not be released on exit.

() expects the directory and file vnodes to be locked on entry and will leave the vnodes locked on return.

Zero is returned if the file was linked successfully, otherwise an error is returned.

The file has too many links.
[]
The file is immutable.
[]
A hard link is not possible between different file systems.

vn_lock(9), vnode(9)

This manual page was originally written by Doug Rabson.

July 24, 1996 FreeBSD-12.0