man.bsd.lv manual page server

Manual Page Search Parameters

VOP_FSYNC(9) Kernel Developer's Manual VOP_FSYNC(9)

VOP_FSYNCflush file system buffers for a file

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_FSYNC(struct vnode *vp, int waitfor, struct thread *td);

This call flushes any dirty file system buffers for the file. It is used to implement the sync(2) and fsync(2) system calls.

Its arguments are:

vp
The vnode of the file.
waitfor
Whether the function should wait for I/O to complete. Possible values are:
Synchronously wait for I/O to complete.
Start all I/O, but do not wait for it.
Push data not written by file system syncer.
td
The calling thread.

The file should be locked on entry.

Zero is returned if the call is successful, otherwise an appropriate error code is returned.

[]
The file system is full.
[]
Quota exceeded.

vnode(9)

This manual page was written by Doug Rabson.

July 24, 1996 FreeBSD-12.0