man.bsd.lv manual page server

Manual Page Search Parameters

VOP_ALLOCATE(9) Kernel Developer's Manual VOP_ALLOCATE(9)

VOP_ALLOCATEallocate storage for a file

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_ALLOCATE(struct vnode *vp, off_t *offset, off_t *len);

This call allocates storage for a range of offsets in a file. It is used to implement the posix_fallocate system call.

Its arguments are:

vp
The vnode of the file.
offset
The start of the range to allocate storage for in the file.
len
The length of the range to allocate storage for in the file.

The offset and len arguments are updated to reflect the portion of the range that still needs to be allocated on return. A partial allocation is considered a successful operation. The file's contents are not changed.

The file should be exclusively locked on entry and will still be locked on exit.

Zero is returned if the call is successful, otherwise an appropriate error code is returned.

[]
An attempt was made to write a file that exceeds the process's file size limit or the maximum file size.
[]
The file system is full.
[]
An append-only flag is set on the file, but the caller is attempting to write before the current end of file.

vnode(9), VOP_READ(9), VOP_WRITE(9)

October 3, 2013 FreeBSD-12.0