man.bsd.lv manual page server

Manual Page Search Parameters

VOP_ADVLOCK(9) Kernel Developer's Manual VOP_ADVLOCK(9)

VOP_ADVLOCKadvisory record locking

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/fcntl.h>
#include <sys/lockf.h>

int
VOP_ADVLOCK(struct vnode *vp, caddr_t id, int op, struct flock *fl, int flags);

The arguments are:
vp
The vnode being manipulated.
id
The id token which is changing the lock.
op
The operation to perform (see fcntl(2)).
fl
Description of the lock.
flags
One of more of the following:

Shared or read lock.
Unlock.
Exclusive or write lock.
Wait until lock is granted.
Use flock(2) semantics for lock.
Use POSIX semantics for lock.

This entry point manipulates advisory record locks on the file. Most file systems delegate the work for this call to ().

Zero is returned on success, otherwise an error is returned.

fcntl(2), flock(2), vnode(9)

This manual page was written by Doug Rabson.

June 30, 1999 FreeBSD-12.0