man.bsd.lv manual page server

Manual Page Search Parameters

VFS_UNMOUNT(9) Kernel Developer's Manual VFS_UNMOUNT(9)

VFS_UNMOUNTunmount a file system

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_UNMOUNT(struct mount *mp, int mntflags);

The () macro unmounts a file system.

The arguments it expects are:

mp
The file system.
mntflags
Bit-mask of flags for the unmount operation. The flags currently supported by () are:
Open files are forcibly closed before the file system is unmounted.

vflush(9), VFS(9), vnode(9)

This manual page was written by Doug Rabson.

May 23, 2009 FreeBSD-12.0