man.bsd.lv manual page server

Manual Page Search Parameters

BUF_UNLOCK(9) Kernel Developer's Manual BUF_UNLOCK(9)

BUF_UNLOCKunlocks a locked buffer

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>

void
BUF_UNLOCK(struct buf *bp);

The () function unlocks a buffer that was previously locked with () or ().

Its argument is:

bp
The buffer to unlock. The buffer must already be locked.

buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), lockmgr(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.

July 9, 2001 FreeBSD-12.0