man.bsd.lv manual page server

Manual Page Search Parameters

PMAP_ZERO(9) Kernel Developer's Manual PMAP_ZERO(9)

pmap_zero_page, pmap_zero_area, pmap_zero_idlezero-fill a page using machine-dependent optimizations

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_zero_page(vm_page_t m);

void
pmap_zero_page_area(vm_page_t m, int off, int size);

void
pmap_zero_page_idle(vm_page_t m);

The () function zero-fills an entire page using machine-dependent optimizations. The () function is used to zero-fill an area of a page. The range specified must not cross a page boundary; it must be contained entirely within a single page.

The () interface is used by the vm_pagezero process. The system-wide Giant lock should not be required to be held in order to call this interface.

This function is required to be implemented for each architecture supported by FreeBSD.

bzero(3), pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 21, 2003 FreeBSD-11.1