man.bsd.lv manual page server

Manual Page Search Parameters

CXGBETOOL(8) System Manager's Manual CXGBETOOL(8)

cxgbetoolUserspace companion to cxgbe(4)

cxgbetool provides command-line access to features and debug facilities exported by cxgbe(4) via private ioctls. The target nexus device, t4nex%d , is always the first argument. (The parent nexus for an Ethernet port cxgbe%d is listed in dev.cxgbe.%d.%parent in the sysctl(8) MIB). The rest consists of a command and any parameters required by that command.

port_id
Clear all transmit, receive, and error statistics of all queues associated with a port. The total number of ports attached to a nexus is listed in dev.t4nex.%d.nports and the 0 based port_id identifies a port within this range.

Display hardware context for an ingress queue, congestion manager, egress queue, or freelist manager.
ingress_cntxt_id
context id of an ingress queue -- the value listed in one of dev.t4nex.%d.fwq.cntxt_id, dev.cxgbe.%d.rxq.%d.cntxt_id, or dev.cxgbe.%d.ofld_rxq.%d.cntxt_id.
egress_cntxt_id
context id of an egress queue -- the value listed in one of dev.t4nex.%d.mgmtq.cntxt_id, dev.cxgbe.%d.txq.%d.cntxt_id, dev.cxgbe.%d.ctrlq.%d.cntxt_id, dev.cxgbe.%d.ofld_txq.%d.cntxt_id, dev.cxgbe.%d.rxq.%d.fl.cntxt_id, or dev.cxgbe.%d.ofld_rxq.%d.fl.cntxt_id. Note that freelists are egress queues too.
flm_cntxt_id
context id of a freelist manager. The FLM context id is displayed in the egress context dump of a freelist as FLMcontextID.
[match-criteria ...]
Display or set the nexus's filter mode. match-criteria is a whitespace separated list of criteria from the table below. Each criteria has an associated budget which is also listed in the table. The total budget allowed is 36 and attempts to set a filter mode that exceeds this will be rejected. Every filter must conform to the filter mode -- multiple match criteria per filter are allowed but only from among those in the current setting of the filter mode. The filter mode can only be changed when there are no existing filters. Its default value is ipv4 ipv6 sip dip sport dport matchtype proto vlan iport fcoe

(Note that mask defaults to all 1s when not provided explicitly. Also note that many of the items being matched are discrete numeric values rather than bit fields and should be masked with caution.)

Criteria Budget Usage Matches if ...
ipv4 0 type ipv4 incoming packet is an IPv4 datagram.
ipv6 0 type ipv6 incoming packet is an IPv6 datagram.
sip 0 sip Ar addr Ns Op / Ns Ar mask bitwise and of the source address in an incoming IP datagram with mask equals addr Ns . addr can be an IPv4 or IPv6 address.
dip 0 dip Ar addr Ns Op / Ns Ar mask bitwise and of the destination address in an incoming IP datagram with mask equals addr Ns . addr can be an IPv4 or IPv6 address.
sport 0 sport Ar port Ns Op : Ns Ar mask bitwise and of the source port in an incoming TCP or UDP datagram with mask equals port Ns .
dport 0 dport Ar port Ns Op : Ns Ar mask bitwise and of the destination port in an incoming TCP or UDP datagram with mask equals port Ns .
fcoe 1 fcoe Brq 0 | 1 incoming frame is Fibre Channel over Ethernet(1) or not(0).
iport 3 iport Ar val Ns Op : Ns Ar mask bitwise and of the ingress port with mask equals val Ns . The ingress port is a 3 bit number that identifies the port on which a frame arrived. Physical ports are numbered 0-3 and 4-7 are internal loopback paths within the chip. Note that ingress port is not a bit field so it is not always possible to match an arbitrary subset of ingress ports with a single filter rule.
ovlan 17 ovlan Ar tag Ns Op : Ns Ar mask bitwise and of the 16-bit outer VLAN tag of an incoming frame with mask equals tag Ns .
vlan 17 vlan Ar tag Ns Op : Ns Ar mask bitwise and of the 16-bit VLAN tag of an incoming QinQ frame with mask equals tag Ns . The inner VLAN tag is used if the incoming frame is QinQ.
tos 8 tos Ar val Ns Op : Ns Ar mask bitwise and of the 8-bit IP Type of Service/IPv6 Traffic Class in an incoming packet with mask equals val Ns .
proto 8 proto Ar ipproto Ns Op : Ns Ar mask bitwise and of the 8-bit IP protocol in an incoming packet with mask equals ipproto Ns .
ethtype 16 ethtype Ar type Ns Op : Ns Ar mask bitwise and of the 16-bit Ethernet type field of an incoming frame with mask equals type Ns .
macidx 9 macidx Ar idx Ns Op : Ns Ar mask bitwise and of the MAC Address Match Index of an incoming frame with mask equals idx Ns . The MAC Address Match Index refers to an entry in the MPS TCAM or in the MPS hash. See matchtype for more information.
matchtype 3 matchtype Ar type Ns Op : Ns Ar mask bitwise and of the Match Type of an incoming frame with mask equals idx Ns . Match Type is one of the following: -tag -width "n" -compact 0 destination MAC in incoming frame is a unicast L2 address that is programmed in the MPS TCAM. macidx can be used to match the index (and thus the MAC address) of the match in the TCAM. 1 destination MAC in incoming frame is a unicast L2 address that "hit" a hash entry in the MPS hash table. macidx can be used to match the index of the entry in the MPS hash table. 2 destination MAC in incoming frame is a multicast L2 address that is programmed in the MPS TCAM. macidx can be used to match the index (and thus the MAC address) of the match in the TCAM. 3 destination MAC in incoming frame is a multicast L2 address that "hit" an entry in the MPS hash table. 4 interface on which incoming frame was received is in promiscuous mode and the destination MAC in the frame is not a broadcast address, and does not match in the MPS TCAM or the MPS hash either. (The frame would have been discarded if the interface wasn't in promiscuous mode.) 5 interface on which incoming frame was received is in promiscuous mode and the destination MAC in the frame is not a broadcast address; it wasn't looked up in the MPS TCAM or the MPS hash because the chip is configured to give precedence to promiscuous mode classification. 6 destination MAC in incoming frame is a broadcast address. 7 Not documented. Do not use.
frag 1 frag Brq 0 | 1 incoming frame is part of a fragmented IP datagram(1) or not(0).
idx filter-specification
Program a filter at the index specified by idx. filter-specification consists of one or more matches to try against an incoming frame and an action to perform when all matches succeed.
idx delete
Delete filter that is at the given index.
list
List all filters programmed into the hardware.
port_id devaddr addr [len]
fw-config.txt
Install the firmware configuration file contained in fw-config.txt to the card. Set hw.cxgbe.config_file="flash" in loader.conf to get cxgbe(4) to use the on-flash configuration.
clear
Erase configuration file from the card.
fw-image.bin
Install the firmware contained in fw-image.bin to the card.
addr len
Display len bytes of data of the card's memory starting at addr. The card's memory map is available in dev.t4nex.%d.misc.meminfo.
{reg | reg64} addr[=val]
[register-block ...]
Display contents of device registers. One or more register-block can be specified to limit the registers displayed. The default is to display registers for all blocks. Registers with read side effects are not read during a regdump operation. register-block can be sge pci dbg mc ma edc0 edc1 cim tp ulp_rx ulp_tx pmrx pmtx mps cplsw smb i2c mi uart pmu sf pl le ncsi xgmac.
[param value]
Configure optional feature capabilities for the TX scheduler.
scheduler-type
Use packet for the packet scheduler.
value
A non-zero value will enable "minmax" mode; a zero value will disable "minmax" mode.

NOTE: Many (most) of the parameters and constraints are adapter-specific - for instance the number of channels and classes which are available whether various modes are implemented, etc. Consult the adapter documentation for specific information on any limitations.

[param value]
Configure parameters for a scheduling class.
scheduler-type
Use packet for packet scheduler.
scheduler-hierarchy-level
The "level" within the scheduling hierarchy which is being programed:

Class Rate Limiting.

Class Weighted Round Robin.

Channel Rate Limiting.
scheduler-mode
The mode in which the scheduling class is going to operate:

All of the "flows" bound to the scheduling class will be held to aggregate scheduling constraints.

Each of the "flows" bound to the scheduling class will be held to the scheduling constraints.

E.g. if the scheduling class has a TX bandwidth of 10Mb/s, in class mode, all of the "flows" bound to the class would be limited to an aggregate bandwidth of 10Mb/s; but in flow mode, each of the "flows" bound to the scheduling class would be limited to 10Mb/s.

scheduler-rate-unit
The units of the scheduler rate constraints:

bit rate in Kb/s.

packets/s.
scheduler-rate-mode
The mode of the scheduler rate constraints:

percent of port rate.

Kb/s.
scheduler-channel-index
The scheduling channel to which the scheduling class will be bound.
scheduler-class-index
The scheduling class being programmed.
minimum-rate
The minimum guaranteed rate to which a rate-limiting scheduling class hierarchy will have access.
maximum-rate
The maximum rate for a rate-limiting scheduling class hierarchy.
round-robin-weight
The weight to be used for a weighted-round-robin scheduling hierarchy.
average-packet-size
The average packet size will be used to compute scheduler constraints for a rate-limited scheduler class hierarchy.

NOTE: Many (most) of the parameters and constraints are adapter-specific - for instance the number of channels and classes which are available, whether various modes are implemented, etc. Consult the adapter documentation for specific information on any limitations.

port queue class
Bind the indicated port's NIC TX queue to the specified TX Scheduler class. If the TX queue is all, * or any negative value, the binding will apply to all of the TX queues associated with the interface. If the class is unbind, clear or any negative value, the TX queue(s) will be unbound from any current TX Scheduler Class binding.
Switch to interactive mode.
tid
Display contents of the hardware TCB (TCP Control Block) for the connection identfied by tid.

/sys/dev/cxgbe/t4_ioctl.h

This manual page was written by Navdeep Parhar ⟨np@FreeBSD.org⟩.

March 6, 2017 FreeBSD-11.1