man.bsd.lv manual page server

Manual Page Search Parameters

VGONE(9) Kernel Developer's Manual VGONE(9)

vgoneprepare a vnode for reuse

#include <sys/param.h>
#include <sys/vnode.h>

void
vgone(struct vnode *vp);

The () function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list.

If the vnode has a v_usecount of zero, and its VIRF_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode is about to be reused, or its file system is being unmounted.

The () function takes an exclusively locked vnode, and returns with the vnode exclusively locked.

vnode(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.

December 8, 2019 FreeBSD-13.0