man.bsd.lv manual page server

Manual Page Search Parameters

NG_TEE(4) Device Drivers Manual NG_TEE(4)

ng_teenetgraph ``tee'' node type

#include <netgraph/tee/ng_tee.h>

The tee node type has a purpose similar to the tee(1) command. Tee nodes are useful for debugging or “snooping” on a connection between two netgraph nodes. Tee nodes have four hooks, right, left, right2left, and left2right. All data received on right is sent unmodified to hooks left and right2left. Similarly, all data received on left is sent unmodified to both right and left2right.

Packets may also be received on right2left and left2right; if so, they are forwarded unchanged out hooks right and left, respectively.

This node type supports the following hooks:

The connection to the node on the right.
The connection to the node on the left.
Tap for right to left traffic.
Tap for left to right traffic.

This node type supports the generic control messages, plus the following.

Get statistics, returned as a struct ng_tee_stats.
Clear statistics.

This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.

tee(1), netgraph(4), ngctl(8)

The ng_tee node type was implemented in FreeBSD 4.0.

Julian Elischer <julian@FreeBSD.org>

January 19, 1999 DragonFly-5.6.1