man.bsd.lv manual page server

Manual Page Search Parameters
KPRINTF(9) Kernel Developer's Manual KPRINTF(9)

kprintf, ksprintf, ksnprintf, kvprintf, kvsprintf, kvsnprintf, krateprintf, tprintf, uprintf, logformatted output conversion

#include <sys/types.h>
#include <sys/systm.h>

int
kprintf(const char *format, ...);

int
ksprintf(char *str, const char *format, ...);

int
ksnprintf(char *str, size_t size, const char *format, ...);

int
kvprintf(const char *format, __va_list ap);

int
kvsprintf(char *str, const char *format, __va_list ap);

int
kvsnprintf(char *str, size_t size, const char *format, __va_list ap);

void
krateprintf(struct krate *rate, const char *format, ...);

int
uprintf(const char *format, ...);

#include <sys/tprintf.h>

int
tprintf(struct proc *p, int pri, const char *format, ...);

#include <sys/syslog.h>

int
log(int pri, const char *format, ...);

The kprintf family of functions are similar to the printf(3) family of functions. The different functions each use a different output stream. The () function outputs to the current process' controlling tty, while (), (), (), (), () and () write to the console as well as to the logging facility. The () function outputs to the tty associated with the process p and the logging facility if pri is not -1. The log() function sends the message to the kernel logging facility, using the log level as indicated by pri.

Each of these related functions use the format, str, size and va parameters in the same manner as printf(3). However, the kprintf functions add another conversion specifier to format:

The %pb%i identifier expects two arguments: an char * and a int. These are used as a register value and a print mask for decoding bitmasks. The print mask is made up of two parts: the base and the arguments. The base value is the output base expressed as an integer value; for example, \10 gives octal and \20 gives hexadecimal. The arguments are made up of a sequence of bit identifiers. Each bit identifier begins with an integer value which is the number of the bit (starting from 1) this identifier describes. The rest of the identifier is a string of characters containing the name of the bit. The string is terminated by either the bit number at the start of the next bit identifier or NUL for the last bit identifier.

The () function uses syslog(3) level values LOG_DEBUG through LOG_EMERG for its pri parameter (mistakenly called ‘priority’ here). Alternatively, if a pri of -1 is given, the message will be appended to the last log message started by a previous call to log(). As these messages are generated by the kernel itself, the facility will always be LOG_KERN.

The () function is a rate controlled version of (). The freq member of the struct krate pointed to by rate must be initialized with the desired reporting frequency. A freq of 0 will result in no output. Initializing count to a negative value allows an initial burst.

The kprintf(), ksprintf(), ksnprintf(), kvprintf(), kvsprintf(), kvsnprintf(), tprintf(), uprintf(), and log() functions return the number of characters displayed.

This example demonstrates the use of the %pb%i conversion specifier. The function

void
kprintf_test(void)
{

	kprintf("reg=%pb%i\n", "\10\2BITTWO\1BITONE\n", 3);
}

will produce the following output:

reg=3<BITTWO,BITONE>

The call

log(LOG_DEBUG, "%s%d: been there.\n", sc->sc_name, sc->sc_unit);

will add the appropriate debug message at priority “kern.debug” to the system log.

printf(3), syslog(3)

December 21, 2012 DragonFly-5.6.1