man.bsd.lv manual page server

Manual Page Search Parameters

IASL(8) System Manager's Manual IASL(8)

iaslACPI Source Language compiler, ACPI table compiler, and AML disassembler

iasl [option ...] [file ...]

The following options are supported:
file
Specify command file.
Enable reference typechecking.
Create converter debug file (*.cdb).
Create debug file (full tree only) (*.txt).
depth
Prune ASL parse tree.
Create debug file (parse tree only) (*.txt).
type
Object type to be pruned from the parse tree.
Convert legacy-ASL source file to new ASL+ file (Original comments are passed through to ASL+ file).
Disable Resource Descriptor error checking.
file1 [file2]
Disassemble or decode binary ACPI tables to file (*.dsl). The file2 is optional, file type is automatically detected.
symbol
Define symbol for preprocessor use.
file ...
Disassemble multiple tables from single namespace.
Do not translate Buffers to Resource Templates.
file ...
Disassemble AML and immediately compile it. Obtain the DSDT from the current system if no input file has it.
Force the disassembler to assume the table contains valid AML.
Emit legacy ASL code only (no C-style operators).
Set verbose option.
file ...
Include ACPI table(s) for external symbol resolution.
Ignore errors, force creation of AML output file(s).
file
Specify external symbol declaration file.
Compile custom table that contains generic operators.
Display the help message.
Display operators allowed in constant expressions.
Info for obtaining and disassembling binary ACPI tables.
Display help for output filename generation.
Display ACPI reserved method names.
Display currently supported ACPI table names.
directory
Specify additional include directory.
Create include file in assembler (*.inc).
Create include file in C (*.h).
When disassembling, ignore NoOp opcodes. When compiling, ignore NoOp operators.
When compiling, create mixed listing file (ASL source and AML) (*.lst). When disassembling, disassemble to mixed ASL and AML code.
Create preprocessed output file (*.i).
Create hardware summary map file (*.map).
Create namespace file (*.nsp).
Create combined source file (expanded includes) (*.src).
Create cross-reference file (*.xrf).
size
Set internal line buffer size (in Kbytes).
Parse only, no output generation.
Disable all optimizations (compatibility mode).
Display compile times and statistics.
Disable disassembler code optimizations.
Disable constant folding.
Disable integer optimization to Zero/One/Ones.
Disable named reference string optimization.
Disable typechecking.
Preprocess only and create preprocessor output file (*.i).
prefix
Specify path/filename prefix for all output files.
Disable preprocessor.
revision
Override table header Revision (1-255).
Create source file in assembler (*.asm).
Create source file in C (*.c).
Create offset table in C (*.offset.h).
sig ... | ALL
Create ACPI table template/example files.
count
Emit DSDT and count SSDTs to same file.
Create hex AML table in assembler (*.hex).
Create hex AML table in C (*.hex).
Create hex AML table in ASL (*.hex).
Display compiler version.
Disable all errors/warnings/remarks.
Display compiler build date and time.
Report only errors (ignore warnings and remarks).
Less verbose errors and warnings for use with IDEs.
Enable optimization comments.
Disable remarks.
Disable signon.
Create verbose template files (full disassembly).
Dump binary table data in hex format within output file.
message_id
Ignore specific error, warning or remark.
message_id
Expect a specific warning, remark, or error.
1 | 2 | 3
Set warning reporting level.
Report warnings as errors.
messageid
Report a specific warning or remark as error.
level
Set debug level for trace output.
Do not insert new compiler ID for DataTables.

acpi(4), acpibin(8), acpicall(8), acpiconf(8), acpidump(8), acpiexec(8), acpihelp(8), acpinames(8), acpixtract(8)

https://acpica.org/documentation/

https://acpica.org/sites/acpica/files/aslcompiler_9.pdf

The iasl utility is provided by Intel as part of their distribution.

This manual page was written by Sascha Wildner.

December 14, 2018 DragonFly-5.6.1