man.bsd.lv manual page server

Manual Page Search Parameters

ERRNO(9) Kernel Developer's Manual ERRNO(9)

errnokernel internal error numbers

#include <sys/errno.h>

This section provides an overview of the error numbers used internally by the kernel and indicate neither success nor failure. These error numbers are not returned to userland code.

Kernel functions that indicate success or failure by means of either 0 or an errno(2) value sometimes have a need to indicate that “special” handling is required at an upper layer or, in the case of ioctl(2) processing, that “nothing was wrong but the request was not handled”. To handle these cases, some negative errno(2) values are defined which are handled by the kernel before returning a different errno(2) value to userland or simply zero.

The following is a list of the defined names and their meanings as given in <errno.h>.

-1 ERESTART .
The system call should be restarted. This typically means that the machine dependent system call trap code will reposition the process's instruction pointer or program counter to re-execute the current system call with no other work required.
-2 EJUSTRETURN .
No more work is required and the function should just return.
-3 ENOIOCTL .
The ioctl(2) was not handled and should be passed through to another layer.
-4 EMOUNTEXIT .
Specific to mfs(8).

errno(2), ioctl(9)

An errno manual page appeared in Version 6 AT&T UNIX. This errno manual page appeared in NetBSD 3.0.

May 16, 2018 DragonFly-5.6.1