man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_GET_CHILDREN(9) Kernel Developer's Manual DEVICE_GET_CHILDREN(9)

device_get_childrenget a list of devices connected to a device

#include <sys/param.h>
#include <sys/bus.h>

int
device_get_children(device_t dev, device_t **devlistp, int *devcountp);

Retrieve a list of all device instances currently connected to dev and return the list in *devlistp and the count in *devcountp. The memory allocated for the list should be freed using (*devlistp, M_TEMP).

Zero is returned on success, otherwise an appropriate error is returned.

devclass(9), device(9)

This man page was written by Doug Rabson.

December 1, 1999 DragonFly-5.6.1