man.bsd.lv manual page server

Manual Page Search Parameters

VFS_SYNC(9) Kernel Developer's Manual VFS_SYNC(9)

VFS_SYNCflush unwritten data

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_SYNC(struct mount *mp, int waitfor, struct ucred *cred, struct proc *p);

This writes out all unwritten data in a filesystem.

Its arguments are:

mp
The filesystem.
waitfor
Whether the function should wait for I/O to complete.
cred
The caller's credentials.
p
The calling process.

This would normally call VOP_FSYNC(9) for all the vnodes in the filesystem.

fsync(2), sync(2), VFS(9), vnode(9), VOP_FSYNC(9)

This man page was written by Doug Rabson.

July 24, 1996 DragonFly-5.6.1