man.bsd.lv manual page server

Manual Page Search Parameters

VFS_STATFS(9) Kernel Developer's Manual VFS_STATFS(9)

VFS_STATFSreturn filesystem status

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_STATFS(struct mount *mp, struct statfs *sbp, struct ucred *cred);

This call returns various pieces of information about the filesystem, including recommended I/O sizes, free space, free inodes, etc.

Its arguments are:

mp
The filesystem.
sbp
Return parameter for the filesystem's status.
cred
Credentials for the process which is querying the filesystem.

VFS(9), vnode(9)

This man page was written by Doug Rabson.

September 1, 2011 DragonFly-5.6.1