man.bsd.lv manual page server

Manual Page Search Parameters

VFS_SET(9) Kernel Developer's Manual VFS_SET(9)

VFS_SETset up loadable file system vfsconf

#include <sys/param.h>
#include <sys/kernel.h>
#include <sys/module.h>
#include <sys/mount.h>

void
VFS_SET(struct vfsops *vfsops, fsname, int flags);

() creates a vfsconf structure for the loadable module with the given vfsops, fsname and flags, and declares it by calling DECLARE_MODULE(9) using () as the event handler.

Possible values for the flags argument are:

File system should be statically available in the kernel.
Network exportable file system.
Does not support write operations.
Pseudo file system, data does not represent on-disk files.
Loopback file system layer.
File names are stored as Unicode.

/*
 * fill in the ones we use, and use the vfs_std for the rest.
 */
static struct vfsops myfs_vfsops = {
        myfs_mount,
        vfs_stdstart,
        myfs_unmount,
        myfs_root,
        vfs_stdquotactl,
        myfs_statfs,
        vfs_stdsync,
        vfs_stdvget,
        vfs_stdfhtovp,
        vfs_stdcheckexp,
        vfs_stdvptofh,
        vfs_stdinit,
        vfs_stduninit,
        vfs_stdextattrctl,
};

VFS_SET(myfs_vfsops, skelfs, 0);

DECLARE_MODULE(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.

September 2, 2012 DragonFly-5.6.1