man.bsd.lv manual page server

Manual Page Search Parameters

BUS_ADD_CHILD(9) Kernel Developer's Manual BUS_ADD_CHILD(9)

BUS_ADD_CHILDadd a device node to the tree with a given priority

#include <sys/param.h>
#include <sys/bus.h>

device_t
BUS_ADD_CHILD(device_t bus, device_t parent, int order, const char *name, int unit);

The () method is used by the driver identify routine to add devices to the tree. Please see device_add_child(9) for more details. The interface is similar to device_add_child(9) however, the bus' BUS_ADD_CHILD() is called.

Busses implementing () should insert the device into the tree using device_add_child(9) before adding things such as their own ivars and resource lists to the device.

The BUS_ADD_CHILD() method returns device_t added to the tree, or NULL.

device(9), device_add_child(9), driver(9)

This manual page was written by M. Warner Losh.

December 20, 2009 DragonFly-5.6.1